へーいち の うぇぶろぐ

へーいち が、徒然なるままに記録している雑記帳です。(^_^;)
初心者向けに「コンピュータで困ったときの対処方法」や「コンピュータをより便利に使おう」といった内容を充実させたいと思ってはおりますが、何を隠そう「雑記帳」ですから自分用のメモや備忘録も兼ねることになるでしょう。

<< November 2017 | 1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 21 22 23 24 25 26 27 28 29 30 >>
 
RECENT COMMENT
RECENT TRACKBACK
MOBILE
qrcode
PROFILE
無料ブログ作成サービス JUGEM

  本日:
  昨日:
  累計:
 
ウィンドウがディスプレイの外に...
JUGEMテーマ:コンピュータ

自宅や職場でマルチモニタ環境で使用しているノート PC を外出のために持ち出して使用する際、アプリケーションによっては前回のウィンドウ表示位置を記憶していて、次の起動時に同じモニタの同じ位置に表示しようとするものがある。
しかし前回とモニタ構成が異なり表示しようとするモニタが接続されていないような場合、一般的なマルチモニタ対応のアプリケーションは、接続されているモニタ上にウィンドウを表示するが、アプリケーションの中には接続されていないモニタに表示するものがある。
そうなるとアプリケーションは起動できても、そのアプリケーションを操作できないし見ることもできない...

そんなときは次の手順で、見えないところで起動しているアプリケーションウィンドウを呼び戻そう。
 

1) タスクバーから目的のアプリケーションを選択する(見えないところでウィンドウがアクティブになる)
2) [Alt]+[スペース]を押す(目的のアプリケーションのシステムメニューが展開される)
3) [M]を押す(システムメニューから[移動]を選択したことになる)
4) 矢印キー([↑][↓][←][→]のいずれか)を 1 度押す
5) マウスを適当に動かして見えないところに表示されていたウィンドウを呼び戻す


上記 (4) の操作によって、マウスでウィンドウのタイトルバーを掴んだかのようになるので、隠れているウィンドウが上下左右のどこに隠れているのかわからなくても、(5) でマウスを移動することでウィンドウが見えるはずだ!
 
BIOS設定が保存されない?!
東芝製ノート PC の Satellite J80 (ACPI BIOS 1.20) を中古で購入。
実はシリアル/パラレルポートを搭載した Windows XP 搭載のノート PC が必要で、極端に古いものだと故障が心配なので、なるべく新しいものを探したところ Satellite の J シリーズ購入に至った。

実は PC のパラレルポートと接続して使用する ROM ライターを使用するのが大きな目的。
最近はパラレル(プリンター)ポートを実装したノート PC は皆無に等しい...
# まだまだこういったレガシーなデバイスを使用している人もいるんですYO.

早速パラレルポートに ROM ライターを接続して使用しようとするが、ROM ライター用のアプリケーションがパラレルポートを認識していない。これは想定の範囲内。
Windows のデバイスマネージャーで確認すると "LPT1(ECP)" は正常動作...となっている。
そこで BIOS 画面を起動して "Parallel Port Mode" を "ECP" から "Std. Bi-Direct." に変更して起動する。
自信を持って ROM ライター用のアプリケーションを起動すると、やはりパラレルポートを認識していない。(汗)
再び BIOS 画面を確認すると、先の "Parallel Port Mode" とは別に "Parallel" 項目があり、それが "Not Used" に設定されているではないか。
"Not Used" でもデバイスマネージャーでは認識してるのにな...と思いながらも深く考えずに "LPT1(378H/IRQ7)" に変更。
今度こそ自信を持って ROM ライター用のアプリケーションを起動し、接続ポートを LPT1 に設定して正常動作を確認。
めでたし、めでたし。

ががが、別の日に ROM ライター用のアプリケーションがパラレルポートを認識していないではないか!
BIOS 画面を確認すると、またまた "Parallel" が "Not Used" になっている!!
何度か設定変更、再起動、電源 OFF → ON を繰り返して確認したところ、電源を OFF → ON すると "Parallel" の設定が "Not Used" になってしまう。困ったもんだ。

BIOS のバグか?
それにしても毎回起動時に BIOS 設定するってのもいただけない。アップデートモジュールとかないのか?...
悩みながら BIOS 画面を見ていると、"Device Config." という項目があり "Setup by OS." と設定されている。選択肢は "Setup by OS." と "All Devices" である。
何となく怪しい。
いろいろと調べてみると次のような解説を見つけた。

【Device Config.】ブート時にBIOS が初期化するデバイスを指定します。

Setup by OS(標準値) OS をロードするのに必要なデバイスのみ初期化する。
All Devices すべてのデバイスを初期化する

ふむふむ、やはり怪しい感じ。。
ということで、試しに "All Devices" に設定して再起動、電源 OFF → ON を繰り返してみたところドンピシャ。
"Parallel" の設定が "Not Used" に書き換わることはなくなりました!

Device Config. の設定により意図せず戻ってしまう設定が "Parallel" だけなのか、他にもあるのかまでは確かめていないので、もし設定が戻ってしまうという場合は確認してみてください。

J80 BIOS設定画面

Windows XP Mode の初回起動時に異常終了する
# 随分久しぶりのブログエントリー追加...

最近 Windows 7 上の Windows XP Mode を起動すると、次のエラーとなることがある。
 

Windows Virtual PC は動作を停止しました


Windows XP Mode の起動が異常終了してしまうので、もう一度 Windows XP Mode の起動を行うと今度は正常に起動できる。要するに、PC 起動後の Windows XP Mode 初回起動時は異常終了するが、2度目以降は正常に起動するといった感じ。2度目で正常起動するため気にしないようにして放置していたが、もし2度目以降も起動しなくなったら...と心配になり原因調査開始!
ちなみにイベント ビューアーのログには次のように記録されていた。
 

障害が発生しているアプリケーション名: vmwindow.exe、バージョン: 6.1.7600.16495、タイム スタンプ: 0x4b3c52b9
障害が発生しているモジュール名: unknown、バージョン: 0.0.0.0、タイム スタンプ: 0x00000000
例外コード: 0xc0000005
障害オフセット: 0x0000000000000000
障害が発生しているプロセス ID: 0x2854
障害が発生しているアプリケーションの開始時刻: 0x01cf5f481ee7610e
障害が発生しているアプリケーション パス: C:¥Windows¥system32¥vmwindow.exe
障害が発生しているモジュール パス: unknown
レポート ID: 6c8e5639-cb3b-11e3-9e42-88532eb651c9


よくわからんので Google 先生に聞いてみたところ、どうやら原因は Windows Update により KB2830477 をインストールしたことによる問題っぽい。
KB2830477 をアンインストールして同現象から回復した事例をみつけられたが、一体 KB2830477 って何者か調べてみたところ「性能および信頼性を強化するさまざまな機能が提供され、Windows 7 の操作性が向上します。」とある。
何となくアンインストールしたくないな...と思わせる内容だ。
もうちょっと調べてみると「Windows8.1 または Windows Server 2012 R2 へのリモート接続のための新機能」が含まれているようだ。
しかし KB2830477 のインストールにより「一部のユーザーでスマートカード認証が利用できなくなる」不具合があったりして、配信が停止されたりしたいわくつきのモノのようでもある。
へーいち 的には当面 Windows 8.1 や Windows Server 2012 R2 へのリモートデスクトップ接続を行うことはないし、それよりも Windows XP Mode がサクッと起動しない方が問題なので KB2830477 をアンインストール。

おっ、いい感じ。
サクッと Windows XP Mode が起動できるようになりました。
 
Windows 8 Consumer Preview
Windows 8 Consumer Preview ISO images ダウンロードは コチラ から。
NEC Express5800/S70 タイプRB 購入

NTT-X Store で NEC の格安サーバー機 Express5800/S70 タイプRB を購入しました。
ず〜っと前から購入したかったのですが、再販しても「あっ」という間に売り切れてしまい、なかなかチャンスがありませんでしたが、3/18 ようやく購入できたのでした。
本体 + IOデータ製1GBメモリセットで ¥19,800(ホントはメモリ抱き合わせじゃないほうが嬉しかったケド)。
別途 8GB(4GB×2枚)のメモリを ¥6,570 で購入し、トータル 10GB メモリにしてみた。
締めて ¥26,000 ちょっとです、今のところ。
早速 Windows 7 Ultimate(x64) をインストールしてみた。



エクスペリエンスインデックスはこんな感じ。
あっ、そうそう、ビデオカードはオンボードではなく手持ちの GF9500 を使用しています。
スコア的には十分です。ゲームとかに使用するわけではなく、あくまでも開発用ですから。
そのうちハードディスクを SSD にするつもりなので、しばらくは開発のメインマシンとして活躍してくれるでしょう。
最近ではめずらしく COM ポートが 2 つもあるのが嬉しいのだ!

[Ctrl]+[Alt]+[Del]でタスクマネージャー? Windows セキュリティ?
出張中の某氏から社内にいる私に問い合わせがありました。

2 台の Windows XP Professional の同型 PC があるが、一方は [Ctrl]+[Alt]+[Del] キーを押すとタスクマネージャが表示されるが、もう一方は Windows セキュリティのウィンドウが表示される!
何故だ!、どうしてだ!、サービスパックや更新プログラムも同じようにインストールされているのに...

それはサービスパックや更新プログラムってことではなく、ようこそ画面を使うように構成されているかどうか...が影響してるんですよ。

[Windowsのセキュリティ] を開こうとすると [Windowsタスクマネージャ] が開く

ようこそ画面を使用するように構成されている場合、[Ctrl]+[Alt]+[Del] キーを押すとタスクマネージャが起動します。
ようこそ画面を使用しないように構成されている場合、は Windows セキュリティのウィンドウが表示されます。

ようこそ画面を使用するかどうかは、[コントロールパネル]-[ユーザーアカウント] の [ユーザーのログオンやログオフの方法を変更する] で、「ようこそ画面を使用する」のチェック状態によって決まります。
タスクマネージャーの表示がおかしくなった!?
Windows を使用していてタスクマネージャーの表示がいつもと違った表示になってしまうことがあります。

通常のタスクマネージャーの表示はこんな感じに、タイトルバー、複数のタブが表示されています。


しかし、タイトルバーやタブがなくなり、こんな風に表示されることがあります。


これはタスクマネージャーがおかしくなったわけではなく、タスクマネージャーの 1 つの表示方法で Tiny Footprint モード(というらしい)です。
通常モードの表示ではタスクマネージャーの表示ウィンドウサイズは一定サイズより小さくできませんが、Tiny Footprint モードでは小さく表示することができます。
画面の片隅に常時置いておきたい場合などでは便利に使用できます。

さて、通常モードと Tiny Footprint モードの切り替えですが、タスクマネージャー画面の余白部分(次の赤く塗られた部分)あたりをダブルクリックします。
ダブルクリックのたびに通常モードと Tiny Footprint モードが切り替わります。
「突然、タスクマネージャーの表示がおかしくなった!?」とお思いのアナタ、きっと何かの拍子に余白部分をダブルクリックしてしまったのでしょう。(笑)




Windows 7 の VAIO で DNS サーバーのアドレスが固定になる
へーいち の VAIO(TZ92NS を Windows 7 Ultimate にアップグレードしたもの) で、[IP アドレスを自動的に取得する][DNS サーバーのアドレスを自動的に取得する] の両方にチェックを付けて使用しているのに、インターネットに接続しようとしてもつながらない…
そこでネットワーク設定を確認してみると、何故か [DNS サーバーのアドレスを自動的に取得する] のチェックが外れ、[次の DNS サーバーのアドレスを使う] にチェックがついて、DNS サーバーのアドレスが設定されている...なんて現象を経験しました。
設定される DNS サーバーアドレスは正しいアドレスで、例えば自宅でインターネット接続しているときであればプロバイダから取得した DNS サーバーアドレスが設定されるため、自宅の中で使用している分には影響がないケースが多いが、会社や外出先の公衆無線 LAN に接続してインターネットを利用しようとすると、無効な DNS サーバーが指定されている状態のため接続できない...ということになります。

さて、この問題どうしてくれようか。。
都度 [IP アドレスを自動的に取得する] にチェックを付ければインターネット接続できるとはいえスマートではない。
「これはきっと Windows 7 の問題だ!」と思いつつ Google 先生に聞いてみると、こちら「続報:Windows7 DNS自動取得の設定について」さんを紹介してくれた(敬意をこめてトラックバック)。
「なんと!、類似した現象でかつ VAIO で発生している!」ではないですか。
Windows 7 の問題と疑ってしまいましたが、VAIO にインストールされている VAIO Smart Network というネットワークプロファイルの切り替えを自動的に行ってくれたりするユーティリティが怪しいと。
それでは、そいつを無効にしてしまおうかと思ったのですが、少々短絡的すぎるので、もう少し Google 先生に質問。
すると今度は こちら を紹介された。
これはビンゴっぽいな。
早速 VAIO Smart Network のアップデートプログラムのダウンロードページへ。
対象機種に へーいち の VAIO はない。Windows Vista モデルを Windows 7 にアップグレードしているので当然といえば当然。
気にせずアップデートプログラムをダウンロードしてインストールしてみました。

インストール時に注意すべき点として、ダウンロードページの説明によると、ダウンロードしたプログラムを実行するとインストーラが起動し、旧バージョンのアンインストール後に新バージョンがインストールされると記されているが、へーいち の環境では旧バージョンを残したまま新バージョンがインストールされた。
気持ち悪いので手動で新バージョン、旧バージョンともアンインストール後に新バージョンのみインストールしてみました。

さてこれで問題解決なるか…
しばらく様子をみてみましょ。
「avast! 誤検出」の続報
少し前に書いたエントリ「avast! が誤検出!」の続報です。

窓の杜に情報がアップされました。
・「avast!」が大量のファイルをウイルスと誤検知する問題が一時発生
 ウイルス定義ファイルを最新の“091203-1”へアップデートすることで解決する模様
だそうです。
avast! が誤検出!
どうも今朝 (2009/12/3 朝) から、起動させたフリーソフトの類を「トロイの木馬を検出〜」と誤検出しまくっています。

使用している avast は avast! version 4.8 Home Edition。


このあたり でも騒がれているので、avast の問題なんだろうな。

へーいち の環境では、仮想プリンタタイプの PDF 作成ソフト PrimoPDF を起動した途端に「トロイの木馬を検出〜」ときた。
誤検出とわかっている場合、「削除」や「チェストに移動」を行ってしまうと、そのアプリケーションが使用できなくなってしまうので、「なにもしない」を選択しましょう。

PrimoPDF は「なにもしない」を選択したにもかかわらず、次から起動できなくなってしまった。むむっ。

原因の深追いはしていませんが、とりあえず以下の手順で PrimoPDF の実行モジュールをフルパス指定でチェック対象から外したところ起動できるようになりました。

1)タスクトレイの avast アイコンを右クリックし、[オンラインアクセス保護の管理] を起動。

2)常駐保護画面の下にある [詳細(D)] ボタンを押す。


3)左側のインストール済みのプロバイダから [標準シールド] を選択。


4)[詳細な設定] ボタンを押す。


5)常駐タスクの設定画面で [追加設定] タブに切り替える。


6)[追加] ボタンを押し、検査から除外するアプリケーションをフルパスで指定する。


ちなみに へーいち の環境での PrimoPDF の場合はこんな感じ。
C:¥Program Files¥activePDF¥PrimoPDF¥PrimoPDF.exe

さて、このマシンも avast から Microsoft Security Essentials に乗り換えよう。。

-- 以下更新 --
こちらに追記しました。
「avast! 誤検出」の続報

(C) 2017 ブログ JUGEM Some Rights Reserved.